> For the complete documentation index, see [llms.txt](https://sandyzeng.gitbook.io/kql/llms.txt). Markdown versions of documentation pages are available by appending `.md` to page URLs; this page is available as [Markdown](https://sandyzeng.gitbook.io/kql/kql-quick-guide/need-to-practice-more/mv-expand.md).

# mv-expand

```
SigninLogs
| project TimeGenerated, UserPrincipalName, ConditionalAccessPolicies
| mv-expand ConditionalAccessPolicies
```

<figure><img src="https://3533425259-files.gitbook.io/~/files/v0/b/gitbook-x-prod.appspot.com/o/spaces%2Fbx8yn20QqNJtsVaH9CY7%2Fuploads%2FPw7j12ho8eL2MlonVhzH%2Fimage.png?alt=media&amp;token=6e0db40b-2776-4326-adaf-287e5bff4182" alt=""><figcaption></figcaption></figure>

```
SigninLogs
| project TimeGenerated, UserPrincipalName, ConditionalAccessPolicies
| mv-expand ConditionalAccessPolicies
| evaluate bag_unpack(ConditionalAccessPolicies)
| mv-expand enforcedGrantControls
| project TimeGenerated, UserPrincipalName, displayName, enforcedGrantControls, result
```

![](https://3533425259-files.gitbook.io/~/files/v0/b/gitbook-x-prod.appspot.com/o/spaces%2Fbx8yn20QqNJtsVaH9CY7%2Fuploads%2FkgZFfv2SBpwmSaHT6E58%2Fimage.png?alt=media\&token=f03bea1d-b21f-40b7-bfa7-db75f93e838b)
